SimCraft for Minecraft

!!

Welcome Guest

Dear visitor, welcome to MC Port Central. If this is your first visit here,  you should consider registering to show your support.   By registering you will give us an idea and clear indication of how in demand our work really are and will motivate our porting team to continue there work. We port vanilla mods to Bukkit and you will also find a lot of other related Minecraft material on our Forum.

Author Topic: [Solved] MinecraftForge 1.3.1 (#1818)  (Read 2092 times)

skalleno

  • Newbie
  • *
  • Posts: 20
[Solved] MinecraftForge 1.3.1 (#1818)
« on: January 28, 2012, 04:57:06 PM »
Getting some errors when using the newest forge 1.3.1 for minecraft 1.1. Is there some files missing?

java.lang.NoClassDefFoundError: forge/ISidedInventory
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(Unknown Source)
        at java.lang.ClassLoader.defineClass(Unknown Source)
        at java.security.SecureClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.access$000(Unknown Source)
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at net.minecraft.server.Block.<clinit>(Block.java:88)
        at net.minecraft.server.StatisticList.a(SourceFile:117)
        at net.minecraft.server.StatisticList.<clinit>(SourceFile:52)
        at net.minecraft.server.MinecraftServer.main(MinecraftServer.java:588)
        at org.bukkit.craftbukkit.Main.main(Main.java:134)
Caused by: java.lang.ClassNotFoundException: forge.ISidedInventory
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        ... 17 more
« Last Edit: January 29, 2012, 06:17:39 PM by iceT2 »

Insania

  • Newbie
  • *
  • Posts: 1
Re: MinecraftForge 1.3.1 (#1818)
« Reply #1 on: January 28, 2012, 05:43:33 PM »
Archive looks invalid:
├───minecraftforge-1.3.1-b1.1R1
│   └───net
│       └───minecraft
│           └───server

├───minecraftforge-1.2.4-b1.0.1R1-r4
│   ├───forge
│   └───net
│       └───minecraft
│           └───server

halvors

  • Porter
  • Full Member
  • *****
  • Posts: 162
Re: MinecraftForge 1.3.1 (#1818)
« Reply #2 on: January 28, 2012, 06:45:39 PM »
have the same problem too. It's invalid :( forge folder is missing.

muCkk

  • Administrator
  • Hero Member
  • *****
  • Posts: 1115
Re: MinecraftForge 1.3.1 (#1818)
« Reply #3 on: January 28, 2012, 06:52:23 PM »
I already wrote to Maeyanie, I'm sure it will be fixed soon.

MisterFix

  • Server Owners/Moderators
  • Newbie
  • *
  • Posts: 46
Re: MinecraftForge 1.3.1 (#1818)
« Reply #4 on: January 29, 2012, 09:24:01 AM »
I can not break / set blocks anywhere with Forge 1.3.1 r2. Even with the op perms. This is just me?
« Last Edit: January 29, 2012, 09:25:50 AM by MisterFix »

genogeist

  • Newbie
  • *
  • Posts: 1
Re: MinecraftForge 1.3.1 (#1818)
« Reply #5 on: January 29, 2012, 10:16:47 AM »
I am haveing a similar issue with Forge 1.3.1r2. on a fresh craftbukkit server I added modloader and tested it out and everything was working fine, then I added Forge and when I break a block i get nothing from it and it pops back in 5 seconds. it will let me drop blocks though. I am running it on Windows 7 x 64 with Java 7 x64.

outlawbiker

  • MCPC Server Member
  • Newbie
  • *
  • Posts: 19
Re: MinecraftForge 1.3.1 (#1818)
« Reply #6 on: January 29, 2012, 11:11:06 AM »
I am haveing a similar issue with Forge 1.3.1r2. on a fresh craftbukkit server I added modloader and tested it out and everything was working fine, then I added Forge and when I break a block i get nothing from it and it pops back in 5 seconds. it will let me drop blocks though. I am running it on Windows 7 x 64 with Java 7 x64.
 

im having the same problem too,if i keep trying to place a block in creative mode sometimes it will stay,it almost looks like very very bad lag.

ZorgKirill

  • Newbie
  • *
  • Posts: 2
Re: MinecraftForge 1.3.1 (#1818)
« Reply #7 on: January 29, 2012, 03:33:43 PM »
I have this problem too((

iceT2

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 415
Re: MinecraftForge 1.3.1 (#1818)
« Reply #8 on: January 29, 2012, 06:17:22 PM »
Fixed in Forge 1.3.1 r2

muCkk

  • Administrator
  • Hero Member
  • *****
  • Posts: 1115
Re: [Solved] MinecraftForge 1.3.1 (#1818)
« Reply #9 on: January 29, 2012, 07:41:02 PM »
*CLOSED*
For other issues see:
[MERGED THREADS] Issues with Forge r2 for 1.1 (can't place/destroy blocks or access chests)