SimCraft for Minecraft

!!

Welcome Guest

Dear visitor, welcome to MC Port Central. If this is your first visit here,  you should consider registering to show your support.   By registering you will give us an idea and clear indication of how in demand our work really are and will motivate our porting team to continue there work. We port vanilla mods to Bukkit and you will also find a lot of other related Minecraft material on our Forum.

Author Topic: [Workaround OK] Disconnected after 4 seconds (mcpc-plus-1.6.2-R1.1-forge871-B82)  (Read 3480 times)

michthom

  • Newbie
  • *
  • Posts: 4
I'm having trouble with the latest MCPC - the server seems fine but each time I connect (direct - server is on localhost) I get disconnected after 4 seconds.

I'm on a Mac, with Java Standard Edition version 7 update 25 (build 1.7.0_25-b15)

Here's how I reproduced the problem from a fresh start:
Installed the default Minecraft Launcher
Started a default single player game (1.6.4)
Quit
Restarted the launcher
Edited my profile and started a single player 1.6.2 game
Quit
Used the Forge installer (minecraftforge-installer-1.6.2-9.10.1.871.jar) to update my client only
Restarted the launcher
Switched to the 'Forge' profile
Started a single player 1.6.2 + forge game
Quit
Installed MCPC in my Applications folder:
Renamed mcpc-plus-1.6.2-R1.1-forge871-B82.jar to mcpc-plus.jar
Started it with:

#!/bin/bash
cd "$( dirname "$0" )"
java -Xmx1024M -jar mcpc-plus.jar -o true


Started the launcher and (with the Forge profile) started a multiplayer 1.6.2 game, direct connect to localhost.

I get (in the client):
Connection Lost: End of stream

And in the server log:
17:51:41 [INFO] [playerID][/127.0.0.1:50960] logged in with entity id 4061 at ([world] -244.5, 60.0, 260.5)
17:51:44 [INFO] Connection reset
17:51:44 [INFO] [playerID] lost connection: disconnect.genericReason
17:51:44 [INFO] ?e[playerID] left the game.

Any clues gratefully received!
« Last Edit: September 29, 2013, 09:15:30 PM by michthom »

michthom

  • Newbie
  • *
  • Posts: 4
Re: Disconnected after 4 seconds (mcpc-plus-1.6.2-R1.1-forge871-B82)
« Reply #1 on: September 29, 2013, 07:39:29 PM »
Oops, I meant to add:
I've not installed any additional mods, plugins or resource packs (yet - this is kind of the point of running MCPC+!?)
So the client reports only:
  • Minecraft Coder Pack (8.04)
  • Forge Mod Loader (6.2.62.871)
  • Minecraft Forge (9.10.1.871)
Also, on disconnect the only relevant entry in the ForgeModLoader-client-0.log is:
2013-09-29 18:33:20 [SEVERE] [Minecraft-Client] Reached end of stream for localhost/127.0.0.1

michthom

  • Newbie
  • *
  • Posts: 4

see86

  • Newbie
  • *
  • Posts: 14
Re: Disconnected after 4 seconds (mcpc-plus-1.6.2-R1.1-forge871-B82)
« Reply #3 on: September 29, 2013, 08:21:12 PM »
I have the same error and i tried with a clean server and client juste forge but the problem it's the same.

michthom

  • Newbie
  • *
  • Posts: 4
Re: Disconnected after 4 seconds (mcpc-plus-1.6.2-R1.1-forge871-B82)
« Reply #4 on: September 29, 2013, 09:14:59 PM »
Thanks to generalm13 on GitHub, there is a workaround until the bug gets squished. Disable Anti-XRay in spigot.yml:
(How did you spot the connection generalm13??)

diff -u ./spigot.yml_BACKUP ./spigot.yml
--- ./spigot.yml_BACKUP 2013-09-29 20:11:39.000000000 +0100
+++ ./spigot.yml    2013-09-29 20:11:56.000000000 +0100
@@ -52,7 +52,7 @@
       misc: 32
       other: 64
     anti-xray:
-      enabled: true
+      enabled: false
       engine-mode: 1
       blocks:
       - 1

winterfrost

  • Newbie
  • *
  • Posts: 7
Just wanted to mention that B84 seems to have resolved this problem for me.